Linux環境で必要なライブラリー(Garoon 3.5.xおよび3.7.x)

対象製品:Garoon 3.5.xおよび3.7.x

Linux環境に必要なライブラリーがインストールされていないと、サイボウズ製品を利用できない場合があります。
OSに合わせてRPMパッケージをインストールすると、サイボウズ製品に必要なライブラリーがインストールされます。

RPMパッケージの確認およびインストール方法と、必要なRPMパッケージについては、次の項目を参照してください。

RPMパッケージの確認方法

RPMパッケージがインストールされているかどうかを確認します。

  1. コマンドラインで次のコマンドを実行します。

    rpm -qa --qf "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" | grep [RPMパッケージ名]
    

    例:

    rpm -qa --qf "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" | grep libaio
    
  2. 検索結果を確認します。
    RPMパッケージがインストールされていると、パッケージの情報が表示されます。
    例:

    libaio-0.3.106-3.2.i386
    

RPMパッケージのインストール手順

  1. RPMパッケージが存在するディレクトリーに移動します。
    次のコマンドを実行します。

    cd [RPMパッケージが存在するディレクトリー]
    

    例:

    cd /media/cdrom/RedHat/RPMS
    
  2. 次のコマンドを実行します。

    rpm -ivh [RPMパッケージ名]
    

    例:

    rpm -ivh libaio-0.3.105-2.x86_64.rpm
    

単体構成およびサーバー分離構成で必要なRPMパッケージ

OS RPMパッケージ 備考
Red Hat Enterprise Linux ES/AS (v.4) 32bit版 cyrus-sasl-2.1.19-14.i386
glibc-2.3.4-2.39.i686
libaio-0.3.105-2.i3861
libgcc-3.4.6-9.i3861
libstdc++-3.4.6-9.i3861
ncurses-5.4-15.el4.i386
zlib-1.2.1.2-1.2.i386
  • RPMパッケージのバージョンは、OSのバージョンに合わせて読み替えてください。
  • 1:バージョン3.5.0以降のガルーンで必要になったRPMパッケージです。
  • 2:バージョン3.7.0以降のガルーンで必要になったRPMパッケージです。
64bit版 cyrus-sasl-2.1.19-14.i3861
glibc-2.3.4-2.43.i686
glibc-2.3.4-2.43.x86_64
libaio-0.3.105-2.x86_641
libgcc-3.4.6-11.i3861
libstdc++-3.4.6-11.i3861
ncurses-5.4-15.el4.x86_64
zlib-1.2.1.2-1.2.i386
Red Hat Enterprise Linux 5 32bit版 cyrus-sasl-lib-2.1.22-5.el5_4.3.i386
glibc-2.5-58.i686
libaio-0.3.106-5.i3861
libgcc-4.1.2-50.el5.i3861
libstdc++-4.1.2-50.el5.i3861
ncurses-5.5-24.20060715.i386
zlib-1.2.3-3.i3861
64bit版 bash-3.2-32.el5_9.1.x86_642
cyrus-sasl-lib-2.1.22-5.el5_4.3.i386
glibc-2.5-58.i686
glibc-2.5-58.x86_64
libaio-0.3.106-5.x86_641
libgcc-4.1.2-50.el5.i3861
libstdc++-4.1.2-50.el5.i3861
ncurses-5.5-24.20060715.x86_64
zlib-1.2.3-3.i386
Red Hat Enterprise Linux 6 32bit版 glibc-2.12-1.7.el6.i686
libaio-0.3.107-10.el6.i6861
libgcc-4.4.4-13.el6.i6861
libstdc++-4.4.4-13.el6.i6861
ncurses-libs-5.7-3.20090208.el6.i686
nss-softokn-freebl-3.12.7-1.1.el6.i686
zlib-1.2.3-25.el6.i686
64bit版 bash-4.1.2-15.el6_4.x86_642
compat-libstdc++-296-1.96-144.el6.i686
cyrus-sasl-lib-2.1.23-8.el6.x86_641
cyrus-sasl-lib-2.1.23-13.el6.i6861
db4-4.7.25-16.el6.i6861
glibc-2.12-1.7.el6.i686
glibc-2.12-1.7.el6.x86_64
libaio-0.3.107-10.el6.x86_641
libgcc-4.4.4-13.el6.i6861
libstdc++-4.4.4-13.el6.i6861
ncurses-libs-5.7-3.20090208.el6.x86_64
nss-softokn-freebl-3.12.7-1.1.el6.i6861
nss-softokn-freebl-3.12.7-1.1.el6.x86_64
zlib-1.2.3-25.el6.i686
SUSE Linux Enterprise Server 11 32bit版 cyrus-sasl-2.1.22-182.19.i586
glibc-2.9-13.2.i686
libaio-0.3.104-140.22.i5861
libgcc43-4.3.3_20081022-11.18.i5861
libncurses5-5.6-90.55.i586
libopenssl0_9_8-0.9.8h-30.11.i586
libstdc++43-4.3.3_20081022-11.18.i5861
zlib-1.2.3-106.34.i586
64bit版 cyrus-sasl-32bit-2.1.22-182.19.x86_641
glibc-2.9-13.2.x86_64
glibc-32bit-2.9-13.2.x86_64
libaio-0.3.104-140.22.x86_641
libgcc43-32bit-4.3.3_20081022-11.18.x86_641
libncurses5-5.6-90.55.x86_64
libopenssl0_9_8-32bit-0.9.8h-30.11.x86_64
libstdc++43-32bit-4.3.3_20081022-11.18.x86_641
zlib-32bit-1.2.3-106.34.x86_64

DB分割構成で必要なRPMパッケージ

OS RPMパッケージ 備考
Red Hat Enterprise Linux ES/AS (v.4) 32bit版 curl-7.12.1-11.el4.i3861
cyrus-sasl-2.1.19-14.i386
e2fsprogs-1.35-12.11.el4.i3861
freetype-2.1.9-6.el4.i3861
glibc-2.3.4-2.39.i686
krb5-libs-1.3.4-54.i3861
libaio-0.3.105-2.i3861
libgcc-3.4.6-9.i3861
libidn-0.5.6-1.i3861
libjpeg-6b-33.i3861
libpng-1.2.7-3.el4_5.1.i3861
libstdc++-3.4.6-9.i3861
libxml2-2.6.16-10.i3861
ncurses-5.4-15.el4.i386
openldap-2.2.13-8.i3861
zlib-1.2.1.2-1.2.i386
  • RPMパッケージのバージョンは、OSのバージョンに合わせて読み替えてください。
  • 1:バージョン3.5.0以降のガルーンで必要になったRPMパッケージです。
  • 2:openssl-0.9.8e-7.el5以降のOpenSSLが必要です。
  • 3:Red Hat Enterprise Linux 6.3以前で使用するRPMパッケージです。
  • 4:Red Hat Enterprise Linux 6.4以降で使用するRPMパッケージです。
  • 5:バージョン3.7.0以降のガルーンで必要になったRPMパッケージです。
64bit版 curl-7.12.1-11.1.el4_7.1.x86_641
cyrus-sasl-2.1.19-14.x86_641
e2fsprogs-1.35-12.24.el4.x86_641
freetype-2.1.9-8.el4.6.x86_641
glibc-2.3.4-2.43.x86_64
krb5-libs-1.3.4-62.el4.x86_641
libaio-0.3.105-2.x86_641
libgcc-3.4.6-11.x86_641
libidn-0.5.6-1.x86_641
libjpeg-6b-33.x86_641
libpng-1.2.7-3.el4_7.2.x86_641
libstdc++-3.4.6-11.x86_641
libxml2-2.6.16-12.6.x86_641
ncurses-5.4-15.el4.x86_64
openldap-2.2.13-12.el4.x86_641
zlib-1.2.1.2-1.2.x86_641
Red Hat Enterprise Linux 5 32bit版 curl-7.15.5-9.el5.i3861
cyrus-sasl-lib-2.1.22-5.el5_4.3.i386
e2fsprogs-libs-1.39-23.el5_5.1.i3861
freetype-2.2.1-28.el5_5.1.i3861
glibc-2.5-58.i686
keyutils-libs-1.2-1.el5.i3861
krb5-libs-1.6.1-55.el5.i3861
libaio-0.3.106-5.i3861
libgcc-4.1.2-50.el5.i3861
libicu-3.6-5.16.i3861
libidn-0.6.5-1.1.i3861
libjpeg-6b-37.i3861
libpng-1.2.10-7.1.el5_5.3.i3861
libselinux-1.33.4-5.7.el5.i3861
libsepol-1.15.2-3.el5.i3861
libstdc++-4.1.2-50.el5.i3861
libxml2-2.6.26-2.1.2.8.el5_5.1.i3861
ncurses-5.5-24.20060715.i386
openldap-2.3.43-12.el5_5.3.i3861
openssl-0.9.8e-12.el5_5.7.i6861,2
zlib-1.2.3-3.i386
64bit版 bash-3.2-32.el5_9.1.x86_645
curl-7.15.5-9.el5.x86_641
cyrus-sasl-lib-2.1.22-5.el5_4.3.x86_64
e2fsprogs-libs-1.39-23.el5_5.1.x86_64
freetype-2.2.1-28.el5_5.1.x86_641
glibc-2.5-58.x86_64
keyutils-libs-1.2-1.el5.x86_64
krb5-libs-1.6.1-55.el5.x86_64
libaio-0.3.106-5.x86_641
libgcc-4.1.2-50.el5.x86_64
libicu-3.6-5.16.1.x86_641
libidn-0.6.5-1.1.x86_641
libjpeg-6b-37.x86_64
libpng-1.2.10-7.1.el5_5.3.x86_641
libselinux-1.33.4-5.7.el5.x86_64
libsepol-1.15.2-3.el5.x86_64
libstdc++-4.1.2-50.el5.x86_64
libxml2-2.6.26-2.1.2.8.el5_5.1.x86_64
ncurses-5.5-24.20060715.x86_64
openldap-2.3.43-12.el5_5.3.x86_641
openssl-0.9.8e-12.el5_5.7.x86_642
zlib-1.2.3-3.x86_64
Red Hat Enterprise Linux 6 32bit版 cyrus-sasl-lib-2.1.23-8.el6.i686
freetype-2.3.11-5.el6.i6861
glibc-2.12-1.7.el6.i686
keyutils-libs-1.4-1.el6.i6861
krb5-libs-1.8.2-3.el6.i6861
libaio-0.3.107-10.el6.i6861
libcom_err-1.41.12-3.el6.i6861
libcurl-7.19.7-16.el6.i6861
libgcc-4.4.4-13.el6.i6861
libicu-4.2.1-9.el6.i6861
libidn-1.18-2.el6.i6861
libjpeg-6b-46.el6.i6861, 3
libjpeg-turbo-1.2.1-1.el6.i6861, 4
libpng-1.2.44-1.el6.i6861
libselinux-2.0.94-2.el6.i6861
libssh2-1.2.2-7.el6.i6861
libstdc++-4.4.4-13.el6.i6861
libxml2-2.7.6-1.el6.i6861
ncurses-libs-5.7-3.20090208.el6.i686
nspr-4.8.6-1.el6.i6861
nss-3.12.7-2.el6.i6861
nss-softokn-freebl-3.12.7-1.1.el6.i686
nss-util-3.12.7-1.el6.i6861
openldap-2.4.19-15.el6.i6861
openssl-1.0.0-4.el6.i6861
zlib-1.2.3-25.el6.i686
64bit版 bash-4.1.2-15.el6_4.x86_645
cyrus-sasl-lib-2.1.23-8.el6.x86_64
freetype-2.3.11-6.el6_0.2.x86_641
glibc-2.12-1.25.el6.x86_64
keyutils-libs-1.4-1.el6.x86_641
krb5-libs-1.9-9.el6.x86_641
libaio-0.3.107-10.el6.x86_641
libcom_err-1.41.12-7.el6.x86_641
libcurl-7.19.7-26.el6.x86_641
libgcc-4.4.5-6.el6.x86_64
libicu-4.2.1-9.el6.x86_641
libidn-1.18-2.el6.x86_641
libjpeg-6b-46.el6.x86_643
libjpeg-turbo-1.2.1-1.el6.x86_644
libpng-1.2.44-1.el6.x86_641
libselinux-2.0.94-5.el6.x86_641
libssh2-1.2.2-7.el6.x86_641
libstdc++-4.4.5-6.el6.x86_64
libxml2-2.7.6-1.el6.x86_64
ncurses-libs-5.7-3.20090208.el6.x86_64
nspr-4.8.7-1.el6.x86_641
nss-3.12.9-9.el6.x86_641
nss-softokn-freebl-3.12.9-3.el6.x86_64
nss-util-3.12.9-1.el6.x86_641
openldap-2.4.23-15.el6.x86_641
openssl-1.0.0-10.el6.x86_641
zlib-1.2.3-25.el6.x86_64